Visual Studio 2005, Vista y ASP.Net

Hola amigos:

Ahora que se liberó windows Vista, todos queremos usarlo como equipo de desarrollo y la verdad es que hay bastantes temas a resolver antes de lograr que la cosa ande mas o menos bien. Microsoft recomienda ejecutar Visual Studio 2005 como Administrador, cosa que va contra las recomendaciones de seguridad, ya que despues terminamos subiendo los niveles de permisos para que nuestras aplicaciones funcionen :-).
Ademas hay varios truquitos más que pueden encontrar aqui:
http://msdn2.microsoft.com/en-us/vstudio/aa948853.aspx

Asi y todo, cuando queremos crear un sitio de ASP.Net en IIS, nos dice que IIS no esta instalado. Y esto es debido a que Vista trae II7 y Visual Studio no puede detectarlo. Aqui les dejo 3 pasos para poder habilitar la compatibilidad con II6 y que Visual Studio pueda crear los sitios IIS correctamente.

Saludos,
Eugenio

Paso 1: Ir al panel de control y elegir Desinstalar un programa

Vista y VS2005 (1)

Paso 2: Elegir Activar o Desactivar caracteristicas de Windows

vistayvs2005_2.jpg

Paso 3: Marcar las opciones segun se indica con las fechas rojas

vistayvs2005_3.jpg

Anuncios

5 Comentarios Agrega el tuyo

  1. Libardo dice:

    Hola Eugenio, me tope con tu bloog buscando informacion sobre vista e IIS, me gustaria saber si vista home premium se le puede agregar el IIS.

    Muchas gracias

  2. Laura dice:

    Gracias por tu Blog! Queria saber si Vista Premium tenia IIS y gracias a ti no solo he descubierto q si, sino que además lo he podido configurar de manera adecuada!

  3. Richard dice:

    Instale visual studio 2005 en vista business pero no me funciona el debug, podrías ayudarme con este problema?

  4. Ramiro dice:

    HOLA EUGE..

    instales VS2005 primeramente,
    y luego activé IIS

    NO PUEDO HACER FUcionar mis progrmas

  5. amaro dice:

    Hola Eugenio soy estudiante de Ing. en Sistemas de la UTN FRC, estoy lidiando con iis y aspx no lo puedo hacer andar po el sig error, Error al inicializar AppDomain:/LM/W3SVC/1/ROOT, dentro de V Studio funcionaa todo Ok, y el iis con paginas html anda ok, alguna idea de donde puedo encontrar ayuda por este tema. Muchas Gracias. Felicitaciones Por la Renovación MVP.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s